Matthew Klassen matt at yoursole.com
Fri Aug 12 16:31:32 UTC 2016

I did actually try to 'make install' with the failures, and everything 
looks fine, until you start and you get 'No sockets -- INTERCHANGE 

I've now tried setting up perlbrew with both 5.22.2 and 5.24.0, but I 
end up with the exact same failures on the Interchange install.

I forgot to mention we are using Interchange 5.7.6

I have disabled apparmor on this box.

I'm going to try and set up Vagrant on a fresh install on a different 
system just in case my host OS or hardware is causing some random problem.

Thanks for the help guys!

On 2016-08-11 04:32 PM, Josh Lavin wrote:
> Quoting Matthew Klassen (matt at yoursole.com):
>> Hi Guys,
>> I'm trying to set up our companies existing dev environment in Vagrant
>> (Ubuntu 14.04). We use perlbrew with perl-5.10.1 for the Interchange
>> install. We've set this up on many different machines and it has always
>> worked, but I'm getting failures on the "make test" of the Interchange
>> source in Vagrant. The output is quite verbose, but here it is:
>> PERL_DL_NONLAZY=1 "/home/vagrant/perl5/perlbrew/perls/perl-5.10.1/bin/perl"
>> "-Iblib/lib" "-Iblib/arch" test.pl
>> server/unixmode.......No sockets -- INTERCHANGE SERVER TERMINATING
>> ok 1
> [snip]
>> not ok 2
>> link/unixmode.........not ok 3 (Undefined path for Socket::pack_sockaddr_un
>> at /home/vagrant/perl5/perlbrew/perls/perl-5.10.1/lib/5.10.1/x86_64-linux/Socket.pm
>> line 871, <PID> line 1.
>> )
>> # When the above test fails, it may be due to your ISP or some other
>> # mechanism blocking port 8786.
>> server/inetmode.......The previous Interchange server was not running and
>> probably
>> terminated with an error.
>> ok 4
>> link/inetmode.........ok 5
>> server/control........ok 6
>> 6 tests run -- 2/6 failed.
>> make: *** [test_dynamic] Error 1
> Hi Matthew,
> I've seen `make test` fail quite a bit, but it's usually always on
> "server/control":
> https://github.com/interchange/interchange/issues/104
> It's interesting that yours is failing on "server/unixmode" and
> "link/unixmode" also has the "Undefined path for Socket".
> Have you tried running `make install` anyways?
> I would also be interested if more recent Perls avoid the error in
> vagrant, such as 5.22.0 or 5.24.0.
> Best,
> Josh

More information about the interchange-users mailing list