[ic] "We're sorry..." on 4.9.9 (works okay on all previous releases)

Adrian P Wilkinson junk at puffin.org
Thu Nov 27 02:36:58 EST 2003


I've now tried a completely clean upgrade to 4.9.9 for the second time and
am getting the same results as my first encounted, namely everyone's
favourite error message:

     "We're sorry, the Interchange server is unavailable..."

I've also previously tried an in-place upgrade to 4.9.9 and experience the
same problem, namely that the server works great (very fast!) for a random
amount of time and then becomes unavailable.  Having checked a 'ps auxwww',
the 'interchange' process appears to be running:

     interch  17656  0.0 24.1 32508 28552 ?       S    02:10   0:00

I'm linking via TCP (standard port of 7786) and trying to connect to this
results in the following error:

     [root at invincible src]# telnet localhost 7786
     telnet: connect to address Connection refused

Simply renaming the 'old-interchange' directory back to 'interchange' and
restarting the servers ensures that it runs for some time.  It shouldn't
make any difference but I've used both the previously compiled tlink and a
freshly compiled one from 4.9.9.

Any suggestions as to why it works for five minutes but closes the port to
new connections whilst continuing to run?  The main IC error.log, catalog
error.log and /tmp/icdebug file have no clues in them as to why this is

If it's any help, the last nightly built I tried (about 14 days ago) worked
a charm, so it looks like whatever is killing it has only been checked-in to
the code in the last fortnight.

Regards, Ade.

More information about the interchange-users mailing list